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Bản quyền 

Copyright  PiStructure 

Đã đăng ký Bản quyền. 

PiStructure Beam là nhãn hiệu đã đăng ký của PiStructure.  

Chương trình máy tính PiStructure Beam và tất cả các tài liệu liên quan đều là sản phẩm độc 

quyền và có bản quyền. Quyền sở hữu trên toàn thế giới thuộc về PiStructure. Việc sử dụng trái 

phép các chương trình này hoặc sao chép tài liệu dưới bất kỳ hình thức nào mà không có sự cho 

phép trước bằng văn bản của PiStructure, đều bị nghiêm cấm. 

Không phần nào của ấn phẩm này có thể được sao chép hoặc phân phối dưới bất kỳ hình thức 

nào hoặc bằng bất kỳ phương tiện nào, hoặc được lưu trữ trong cơ sở dữ liệu hoặc hệ thống truy 

xuất mà không có sự cho phép rõ ràng trước bằng văn bản của nhà xuất bản. 

Thông tin thêm và bản sao của tài liệu này có thể được lấy từ: 

PiStructure software, 

http://www.pistructure.com/ 

pistructure @outlook.com (for general information & technical support) 
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1. Mở phần mềm và giao diện 

Nhấn đúp chuột trái vào icon phần mềm trên desktop để mở phần mềm. 

 

Giao diện chương trình khi mở phần mềm 

 

Giao diện chương trình khi mở file model 

Các cứa sổ, thanh toolbar, menu của chương trình có thể linh hoạt điều chỉnh vị trí theo tùy chọn 

của mỗi người dùng bằng cách nhấn giữ chuột và kéo về vị trí muốn đặt. 
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Các cửa sổ Output và Report hiển thị kết quả tính toán theo 2 ngôn ngữ tùy chọn là tiếng Anh 

và tiếng Việt. 

2. Lưu file về máy tính 

Bấm vào menu File > Save hoặc icon, , trên thanh toolbar để lưu file dự án vào thư mục lưu 

trữ của máy tính. 

3. Thao tác với cửa sổ Input Data 

 

Cửa sổ Input Data của chương trình 
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Từ cửa sổ Input Data, người dùng có thể định nghĩa các thông số của mô hình như Story, Frame 

Property, Frame Input Data bằng cách nhấn đúp chuột trái vào các đối tượng chữ trên cửa sổ 

Input Data. 

 

Nhấn đúp chuột trái và chữ “Story” để xuất hiện hộp thoại định nghĩa Story (tầng) 

 

Nhấn đúp chuột trái và chữ “Frame label” hoặc “Unique name” để xuất hiện hộp thoại định 

nghĩa Frame. 
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Nhấn đúp chuột trái và chữ “Frame property data” hoặc “Property name” để xuất hiện hộp 

thoại định nghĩa Frame property 

 

Nhấn đúp chuột trái và chữ “Conrete” để xuất hiện hộp thoại định nghĩa vật liệu bê tông 

Concrete 
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4. Thêm mới một frame để tính toán (dùng như bảng tính thông thường) 

Nếu người dùng muốn tính nhanh các tiết diện như một bảng tính thông thường mà chưa cần 

nhập dữ liệu từ Etabs và Safe thì có thể tự tạo các frame để tính toán, frame được tạo ra nhằm 

mục đích đặt tên (tên gọi và tên tầng) để lưu được dữ liệu mà người dùng đã nhập vào, còn về 

bản chất của chương trình vẫn là nhập các thông tin đầu vào của tiết diện, nội lực rồi tính ra kết 

quả thép cho tiết diện. Việc định nghĩa tên frame, đặc trưng tiết diện, nội lực, vật liệu bê tông, 

cốt thép… của frame có thể bằng cách vào các menu của chương trình hoặc thao tác nhanh trên 

cửa sổ Input Data như đã mô tả ở mục 3. 

Hình dưới mô tả 1 bước nhanh đơn giản để tính cho một tiết diện dầm: Nhấn đúp chuột trái vào 

chữ “Frame label” trên cửa sổ Input Data > Hộp thoại Frame xuất hiện > Nhấn nút Add New 

Frame trên hộp thoại để xuất hiện hộp thoại Frame Information > chọn các đặc trưng tiết diện 

cho Frame và nhập nội lực > nhấn nút OK để hoàn thành việc thêm mới một frame. 

 

1 bước đơn giản để thêm mới Frame vào model 

Sau khi nhấn nút OK, bạn sẽ có ngay các thông tin tính toán của dầm bên cửa sổ Output và cửa 

sổ Report. 
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Cửa sổ Output có ngay kết quả tính toán 

Cửa sổ Project Table cũng đã lưu ngay dầm này vào mô hình của người dùng 
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Cửa sổ Project Table đã lưu dữ liệu của Frame vừa thêm mới 

5. Nhập dữ liệu từ mô hình Etabs hoặc Safe 
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Với phần mềm Etabs thì CSI có hỗ trợ API nên PiStructure Beam đã tích hợp khả năng lấy dữ 

liệu trực tiếp từ mô hình Etabs đang mở mà không cần phải xuất dữ liệu. Còn đối với mô hình 

Safe do chưa hỗ trợ API nên cần người dùng cần xuất dữ liệu từ Safe qua Excel, sau đó 

PiStructure Beam sẽ nhập dữ liệu từ file Excel này.  

5.1. Nhập dữ liệu từ mô hình Etabs đang mở 

Bấm vào menu Import > Etabs model > Version .., để import các dữ liệu của dầm từ kích thước 

hình học, vật liệu cho đến kết quả nội lực của dầm vào model PiStructure Beam. Mô hình Etabs 

đang mở thuộc version nào thì người dùng chọn đúng version đó trên menu. 

Import > Etabs model > Version ..  

Sau đó, hộp thoại Import Etabs Data như hình dưới đây sẽ xuất hiện. 
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Hộp thoại Import Etabs Data 

Chọn các tầng mà người dùng muốn thiết kế và các tổ hợp tương ứng để nhập vào mô hình 

PiStructure Beam, bên dưới mục Option là các lựa chọn mà người dùng có thể tùy chọn. Nếu 

chọn mục Clear all frame data of model and import new data thì mô hình của người dùng sẽ 

được xóa toàn bộ thông tin frame mà người dùng đã nhập trước đó để nhập lại dữ liệu từ đầu 

(lưu ý các tên dầm bản vẽ và thép đã đặt vẫn được giữ nguyên, chỉ xóa các dữ liệu đầu vào từ 

mô hình Etabs). 

Nếu chọn mục Add new forces into model, người dùng sẽ vẫn giữ nguyên các thông tin dữ liệu 

frame đã nhập trước đó, sau đó các frame trong mô hình PiStructure Beam sẽ được thêm các nội 

lực mới.  

Bên dưới mục Design Code, chọn tiêu chuẩn thiết kế áp dụng rồi nhấn nút OK. 
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Chờ đến khi thanh tiến trình chạy xong để hoàn tất quá trình nhập dữ liệu từ mô hình Etabs. 

 

Thanh tiến trình 

Sau khi nhập xong dữ liệu từ Etabs thì giao diện phần mềm sẽ như hình bên dưới 

 

Giao diện phần mềm sau khi nhập xong dữ liệu từ Etabs hoặc Safe 

Thông thường sau khi nhập xong dữ liệu từ Etabs hoặc Safe thì phần mềm sẽ tự động chạy Run 

để tính toán và mô hình bị khóa lại, nhấn vào menu Design > Locked Model để mở khóa mô 

hình để thao tác. 

Menu Design > Locked Model  

5.2. Nhập dữ liệu từ mô hình Safe 

Hiện tại phần mềm PiStructure Beam hỗ trợ nhập dữ liệu từ Safe với các phiên bản Safe 2016 

và Safe 2020. 
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Các bước thực hiện như sau: 

Bước 1. Mở mô hình Safe lên và chạy tính toán 

 

Bước 2. Trong mô hình Safe, hiển thị bảng dữ liệu Safe với tổ hợp tải trọng muốn xuất nội lực 

dầm và sau đó xuất ra file excel (Toàn bộ mục MODEL DEFINITION và chỉ mục 

ANALYSIS RESULTS > Element Forces – Beams). 

 

Hiển thị bảng dữ liệu Safe 
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Xuất toàn bộ bảng dữ liệu Safe ra file Excel và lưu file Excel 

Bước 3. Từ phần mềm PiStructure Beam, bấm vào menu Import > Safe Excel > version …, 

chọn đúng phiên bản của phần mềm Safe đang sử dụng 2016 hoặc 2020. 

Import > Safe Excel  

Sau đó hộp thoại có tên tầng sẽ xuất hiện để chọn tầng cần nhập dữ liệu. 



17 | P a g e  

 

 

Chọn tầng cần nhập dữ liệu rồi nhấn OK. 

Một hộp thoại xuất hiện để người dùng chọn file Excel xuất ra từ SAFE, chọn file Excel đó để 

nhập dữ liệu vào mô hình PiStructure Beam. 

 

Hộp thoại chọn file Excel để nhập dữ liệu 

Tiếp tục chọn kiểu nhập dữ liệu trong hộp thoại xuất hiện rồi nhấn OK. 
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Chờ đến khi thanh tiến trình chạy xong để hoàn tất quá trình nhập dữ liệu từ Safe excel. 

 

Thanh tiến trình 

 

Cửa sổ Plan View sau khi nhập xong dữ liệu từ Safe 

Trong trường hợp mô hình PiStructure Beam có nhiều tầng thì có thể màn hình chưa hiển thị 

tầng vừa nhập dữ liệu. Vào menu View > Set Plan View để hiển thị hộp thoại Set Plan View, 

chọn tầng vừa nhập dữ liệu và nhấn nút OK để cửa sổ Plan View cập nhật mặt bằng mới. 
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View > Set Plan View  

 

Hộp thoại Set Plan View 

6. Tạo mới một dầm bản vẽ 

Trên cửa sổ Plan View, nhấn giữ chuột trái và quét chọn các frame trên mặt bằng sẽ nằm trong 

nhịp con của dầm bản vẽ. Nếu chọn từng dầm bằng cách nhấn chuột trái vào từng frame thì thứ 

tự chọn từ trái sang phải, từ trên xuống dưới. 
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Quét chọn các frame con để đặt tên dầm bản vẽ 

 

Chọn menu Create New Dwg Beam trên menu xuất hiện 

Sau khi chọn xong đủ các frame thì nhấn chuột phải, chọn menu Create New Dwg Beam trên 

menu xuất hiện. Sau đó sẽ xuất hiện hộp thoại All Spans Rebar đã tự động bố trí thép cho dầm 

bản vẽ. Thép này được chương trình tự chọn dựa vào thuật toán tự động bố trí thép dầm (xem 

thêm mục 8 của tài liệu này), các thông số đầu vào để chọn thép tự động có thể được tùy chọn 

bằng cách vào menu Design > Auto Layout Rebar Setting để điều chỉnh. 
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Menu Design > Auto Layout Rebar Setting  

 

Hộp thoại All Spans Rebar tự động bố trí thép trước cho dầm 

Người dùng có thể tùy chỉnh lượng thép dọc, thép đai, thép giá bố trí cũng như thông tin sàn liên 

kết với dầm trên bảng này, các thao tác điều chỉnh trên bảng này cũng tương tự như Excel nên 

người dùng có thể sử dụng bàn phím linh hoạt hơn. 

Sau khi nhấn OK trên hộp thoại hộp thoại All Spans Rebar, xuất hiện hộp thoại Drawing Beam 

Data với giao diện 3D của dầm.  
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Hộp thoại Drawing Beam Data với giao diện 3D của dầm 

Từ giao diện này người dùng có thể chuyển sang 2D View, và tùy chỉnh cao độ, chiều dài nhịp 

của dầm, chiều rộng cột đúng với bản vẽ bằng cách nhấn đúp chuột trái vào dimension của 

dầm/cột.  

 

Nhấn đúp chuột trái vào dimension của dầm/cột để tùy chỉnh thông tin 
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Nhấn chuột phải vào thanh nhịp dầm để xuất hiện hộp thoại Span Rebar. 

Người dùng có thể tùy chỉnh lượng thép dọc và thép đai bố trí trong giao diện 2D/3D bằng cách 

nhấn chuột phải vào thanh nhịp dầm, và điều chỉnh trong hộp thoại Span Rebar.  

Nếu người dùng muốn quay lại điều chỉnh trên giao diện hộp thoại All Spans Rebar dạng bảng 

Excel thì click vào nút Excel Edit Form (hoặc phím F2) để hiển thị lại hộp thoại All Spans Rebar 

dạng bảng Excel. 

 

Hộp thoại All Spans Rebar 

Trên hộp thoại All Spans Rebar, nhấn vào nút Show Auto Rebar Layout để hiển thị thép tự động 

chọn theo phần mềm, sau khi nhấn nút này để hộp thoại Auto Layout Rebar xuất hiện, tùy chọn 
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các thông tin đầu vào rồi nhấn nút OK để hiển thị thép bố trí tự động cho dầm (xem thêm mục 8 

của tài liệu này). Sau khi nhấn các chữ màu đỏ sẽ xuất hiện trong bảng là thép bố trí tự động cho 

dầm theo phần mềm, nhấp nút Apply Auto Rebar Layout nếu người dùng muốn sử dụng thép 

này bố trí cho dầm.  

 

Nhấn vào nút Show Auto Rebar Layout để hiển thị thép tự động (chữ màu đỏ trong bảng) 

 

Nút Apply Auto Rebar Layout 

Nhấn nút OK trên hộp thoại Drawing Beam Data để hoàn tất việc tạo 1 dầm bản vẽ mới. Cửa sổ 

Plan View sẽ tự động cập nhật dầm bản vẽ mới thêm vào mặt bằng. 
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Giao diện cửa sổ Plan View sau khi thêm một dầm bản vẽ mới 

7. Chọn tiêu chuẩn thiết kế 

Chọn menu Design > Setting code > All frame để thiết lập tiêu chuẩn thiết kế cho toàn bộ frame 

trong dự án.  

Menu Design > Setting code > All frame  

Nếu muốn chọn riêng tiêu chuẩn cho từng frame thì người dùng có thể vào menu Define > 

Frame Object để hiển thị hộp thoại Frame quản lý tất cả frame.  

menu Define > Frame Object  
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Hộp thoại Frame để quản lý tất cả frame trong dự án 

Sau đó chọn tên frame muốn thiết lập rồi nhấn nút Modify/Show Frame để chọn tiêu chuẩn thiết 

kế cho frame. 

 

Hộp thoại Frame để điều chỉnh các thông số của từng frame 
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8. Thiết lập các tham số của tiêu chuẩn 

Chọn menu Design > Reference để xuất hiện hộp thoại Code Frame Design Parameters.  

menu Design > Reference  

Trong hộp thoại này ứng với mỗi tiêu chuẩn thiết kế sẽ có các tham số khác nhau. Từ mục code 

trong hộp thoại này, nhấn chuột trái vào để xổ xuống tên các tiêu chuẩn mà người dùng cần kiểm 

tra lại dữ liệu nhập từ tiêu chuẩn. 

 

Hộp thoại Code Frame Design Parameters 

Vì trong nhiều công trình dầm thường được bỏ qua xoắn trong thiết kế nên nếu người dùng 

không muốn thiết kế cốt thép chịu xoắn cho dầm vào bản vẽ thì có thể bỏ tùy chọn trong mục 

Apply Torsion Design For Beam Rebar trên hộp thoại.  

Kiểm tra thêm các thông số phù hợp rồi nhấn nút OK trên hộp thoại. 
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9. Chạy tính toán Run Design 

Sau khi thiết lập tham số của các tiêu chuẩn, chọn menu Design > Run để tính toán thép cho tất 

cả frame. 

menu Design > Run  

Chờ đến khi thanh tiến trình chạy xong để hoàn tất quá trình tính toán thép cho tất cả frame 

 

Thanh tiến trình 

10. Tự động bố trí thép dầm 

Chọn menu Design > Auto Layout Rebar All để phần mềm tự động bố trí thép cho tất cả các 

dầm bản vẽ. Phần mềm sẽ dựa vào lượng thép dọc và thép đai vừa tính toán được để tự động 

chọn ra lượng thép bố trí hợp lý theo yêu cầu của người dùng. 

menu Design > Auto Layout Rebar All  

Để chọn bố trí thép cho từng dầm bản vẽ, có thể làm theo cách khác như sau: 

Trên cửa sổ Plan View, nhấn giữ chuột trái và quét chọn các frame hoặc chọn từng frame bằng 

cách click chuột trái vào từng frame. Sau khi chọn xong đủ các frame thì nhấn chuột phải, chọn 

menu Auto Layout Rebar Single trên menu xuất hiện để tự động bố trí thép cho các dầm chứa 

các frame này, nếu muốn bố trí thép cho dầm bản vẽ nào thì chỉ cần chọn 1 frame nằm trong 

dầm bản vẽ. 
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Chọn menu Auto Layout Rebar Single 

Sau đó hộp thoại Auto layout Rebar sẽ xuất hiện như hình bên dưới. Thiết lập các tùy chọn rồi 

nhấn OK để phần mềm tự động bố trí thép dọc và thép đai cho dầm. 
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Hộp thoại Auto layout Rebar Setting 

11. Xem kết quả kiểm tra bản vẽ dầm 

Trên giao diện phần mềm, cửa sổ Project Table sẽ hiển thị bảng tổng hợp kiểm tra của tất cả các 

dầm trong dự án. Bảng sẽ tô màu xanh các dầm và frame đang xem. 
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Cửa sổ Project Table 

Nếu trên màn hình chưa có cửa sổ này thì nhấn vào menu View > Toolbar and Docking 

Windows > Project Table để hiển thị cửa sổ này. 

View > Toolbar and Docking Windows > Project Table  

Để tùy chọn hiển thi kết quả kiểm tra của tất cả các dầm thì nhấn vào chuột phải trên vùng của 

cửa sổ này để hiển thị Popup Menu, sau đó chọn Setting Display Option trên menu này để xuất 

hiện hộp thoại Output Display Option. 
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Popup Menu trên cửa sổ Project Table 

Chọn các mục muốn hiển thị trên hộp thoại Output Display Option rồi nhấn nút OK để có các 

thông tin cần thiết trên bảng Project Table. 

 

Hộp thoại Output Display Option 
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12. Xem kết quả tổng hợp khối lượng dầm 

Để xem kết quả tổng hợp khối lượng dầm, nhấn vào menu Table > Rebar Quantity Table.  

menu Table > Rebar and Concrete Quantity   

Sau đó bảng khối lượng dầm Rebar and Concrete Quantity sẽ xuất hiện với hình ảnh giao diện 

như hình dưới. 

 

Bảng khối lượng dầm Rebar and Concrete Quantity Table 

Nhấn nút Export Excel trên hộp thoại để xuất file Excel, chương trình mặc định sẽ chọn file 

mẫu trong đường dẫn C:\Program Files\PiStructure\PiStructure-Beam\Template\Excel\, người 

dùng có thể chọn file mẫu khác bằng cách nhấn nút Select Template trước khi nhấn nút Export 

Excel. 

Sau khi thanh tiến trình chạy xong thì hộp file Excel sẽ xuất hiện. Chọn vị trí lưu file và đặt tên 

file. 
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Thanh tiến trình 

Lưu ý: Sau khi nhấn nút Export Excel, có thể thanh tiến trình không xuất hiện ngay hoặc xuất 

hiện hộp thoại báo Server Busy. Lý do có thể là do bản quyền của phần mềm MS Excel. Nhấn 

đồng thời alt + tab để tìm hộp thoại như mũi tên hình dưới rồi bấm Close. 

 

Hộp thoại báo Server Busy 

 

Tìm hộp thoại như hình mũi tên rồi bấm nút Close 
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File excel Bảng khối lượng dầm Rebar Quantity Table sau khi xuất xong 

13. Xuất chi tiết thép dầm dạng bảng 

Để xuất chi tiết thép dầm dạng bảng, vào menu Export > Drawing > Drawing Rebar Schedule.  

menu Export > Drawing > Drawing Rebar Schedule 

 

Hộp thoại Drawing Rebar Schedule sẽ xuất hiện. Nhấn nút Export Excel trên hộp thoại để 

xuất file Excel, chương trình mặc định sẽ chọn file mẫu trong đường dẫn C:\Program 

Files\PiStructure\PiStructure-Beam\Template\Excel\, người dùng có thể chọn file mẫu khác 

bằng cách nhấn nút Select Template trước khi nhấn nút Export Excel. 
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Hộp thoại Drawing Rebar Schedule 

Sau khi thanh tiến trình chạy xong thì hộp file Excel sẽ xuất hiện. Chọn vị trí lưu file và đặt tên 

file. 

 

Thanh tiến trình 

Lưu ý: Sau khi nhấn nút Export Excel, có thể thanh tiến trình không xuất hiện ngay hoặc xuất 

hiện hộp thoại báo Server Busy. Lý do có thể là do bản quyền của phần mềm MS Excel. Nhấn 

đồng thời alt + tab để tìm hộp thoại như mũi tên hình dưới rồi bấm Close. 
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Hộp thoại báo Server Busy 

 

Tìm hộp thoại như hình mũi tên rồi bấm nút Close 

 

File excel Drawing Rebar Schedule sau khi xuất xong 
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14. Xuất chi tiết thép dầm dạng mặt bằng 

Để xuất chi tiết thép dầm dạng bảng, vào menu Export > DXF > Rebar Plan.  

menu Export > Drawing > Rebar Plan  

 

menu Export DXF Rebar Plan trên cửa sổ Plan View 

Sau đó hộp thoại lưu file DXF sẽ xuất hiện. Chọn vị trí lưu file và đặt tên file.  

 

Hộp thoại lưu file DXF 
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15. Xuất chi tiết thép dầm mặt cắt ngang, mặt cắt dọc cho toàn bộ dầm của dự án 

Do phần vẽ chi tiết mặt cắt ngang, mặt cắt dọc dầm cần tương tác trực tiếp trên phần mềm 

AutoCAD, nên PiStructure phát triển thêm phần mềm PiStructure Drafter riêng để triển khai chi 

tiết thép dầm. Vì vậy PiStructure Beam sẽ xuất dữ liệu rồi chuyển sang phần mềm PiStructure 

Drafter để vẽ hàng loạt tất cả chi tiết dầm. 

Để xuất xuất dữ liệu cho phần mềm PiStructure Drafter, vào menu Export > PS Drafter Data  

menu Export > PS Drafter Data   

Sau đó hộp thoại lưu file PiStructure Drafter sẽ xuất hiện. Chọn vị trí lưu file và đặt tên file.  

 

Hộp thoại lưu file PiStructure Drafter 

Sau đó dùng phần mềm PiStructure Drafter để nhập dữ liệu từ file này và vẽ từng dầm hoặc 

vẽ toàn bộ dầm theo nhu cầu của người dùng. 

Chi tiết tham khảo thêm file hướng dẫn sử dụng phần mềm PiStructure Drafter. 

16. Xuất thuyết minh toàn bộ dự án 
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Để xem thuyết minh tổng hợp của toàn bộ dự án, nhấn vào menu Export > Report.  

Menu Export > report   

Sau đó hộp thoại Report sẽ xuất hiện.  

 

Hộp thoại Report 

Tùy chọn hiển thị thông tin bằng cách nhấn nút General Setting để xuất hiện hộp thoại Output 

Display Option. 
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Hộp thoại Output Display Option 

Chọn các mục muốn hiển thị trên hộp thoại Output Display Option rồi nhấn nút OK để có các 

thông tin cần thiết cho Report. 

Nhấn nút Export Word trên hộp thoại để xuất file Word, nhấn nút Print để in file PDF cho 

Report. 

Ngoài ra vẫn có thể xuất file Excel cho Report bằng cáh nhấn nút Export Excel trên hộp thoại 

để xuất file Excel, chương trình mặc định sẽ chọn file mẫu trong đường dẫn C:\Program 

Files\PiStructure\PiStructure-Beam\Template\Excel\, người dùng có thể chọn file mẫu khác 

bằng cách nhấn nút Select Template trước khi nhấn nút Export Excel. 

Sau khi thanh tiến trình chạy xong thì hộp file Excel sẽ xuất hiện. Chọn vị trí lưu file và đặt tên 

file. 

 

Thanh tiến trình 
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Lưu ý: Sau khi nhấn nút Export Excel, có thể thanh tiến trình không xuất hiện ngay hoặc xuất 

hiện hộp thoại báo Server Busy. Lý do có thể là do bản quyền của phần mềm MS Excel. Nhấn 

đồng thời alt + tab để tìm hộp thoại như mũi tên hình dưới rồi bấm Close. 

 

Hộp thoại báo Server Busy 

 

Tìm hộp thoại như hình mũi tên rồi bấm nút Close 
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